Dennis Faas's picture

Microsoft Changes Upgrade Policy on Internet Explorer 9

Earlier this week we reported that the upcoming Internet Explorer 9 web browser would require Windows 7 Service Pack 1 (SP1). Since that post, it appears that Microsoft's website regarding this issue has been changed. For those who have already ... installed the Internet Explorer 9 Beta Edition, the installation process requires a Windows Update, followed by a restart of the operating system (OS). According to Microsoft's updated FAQ, the single most important reason for announcing the Windows 7 Service Pack 1 requirement was to prevent Internet Explorer 9 installations from requiring a system ... (view more)

Dennis Faas's picture

Freeware software DVD player?

Today's visitor feedback is based on the fact that I received two similar emails from Readers on the same day. Infopackets Reader Ric J. writes: " Can you please tell me a good DVD Decoder program to download, because the two I've tried didn't work. ... I'd like to find one that does so I can watch DVD's on my system. Thanks! " And, Felicitaz C. writes: " I have WinDVD 3.1 DVD player and cannot play DVD's anymore. Nothing happens when I try to play a DVD. I tried Help -> Troubleshoot and WinDVD suggested that I install a decoder or upgrade. When I did a little more searching I ... (view more)

Subscribe to RSS - require